HY-BBS论坛源码 v1.0

HY-BBS服务器环境要求:
支持子目录安装论坛
PHP 5.3+ 包括5.3 , 5.3以上环境
Apache || Nginx || IIS
需要开启伪静态,否则无法安装~!
数据库支持 : MYSQL , MSSQL ,Oracle ,SQLite ,PostgreSQL ,Sybase 等..
PHP支持扩展 需要开启 PDO ##### PDO PDO PDO 否则数据库玩不了

HY-BBS简介
HY-BBS以文件缓存形式运行论坛,支持自由的模板与插件开发,所以非常适合二次开发,论坛基于框架开发,很多操作都是非常简单,论坛也封装了Model提供使用,所以二次开发并不需要修改论坛源代码, 只需要增加自己的插件 从中修改论坛。
用户也可以通过模板机制自己开发一套属于自己的模板, 模板拥有框架标签解析引擎, 是非常容易开发的
论坛可承载亿级数据库 运行 0.00x速度, 当然是用了xcache加速编译 , 论坛也在开发测试中. 论坛暂时没开发 数据缓存

HY-BBS目前功能
持续增加核心基础功能
模板引擎 - 随意开发多套模板 随意切换,开发拥有HYPHP 标签解析引擎, 开发只需要CTRL + C随便扒模板
插件引擎 - HOOK机制插入源代码 实现插件 , 开发非常简单 用户系统
登录 - 拥有独立登录页面模板, 可随意切换开发模板替换
注册 - 同上
用户组 - 每个用户组都拥有独立的 权限开关 用户中心
用户个人页面
文章管理
帖子管理
头像更改
密码更改 消息系统
帖子 文章, @ 功能
文章被回复 提醒
帖子 回复 帖子 采用 @ 功能处理 板块分类
分类添加
分类权限管理 - 可对某些用户组禁止做某种事情,
分类版主
子分类 - 继承父分类,可一直子下去
后台管理
后台登录页面 - 需核对当前管理员密码, 可添加多位管理员
网站全局设置 - 一系列的设置
板块分类管理
板块分类版主与权限
用户管理
文章管理
外观与模板
插件
免费虚拟主机环境测试
日本线路 PHP5.3 Linux Apache
通过 phpinfo() 看一下PHP环境, 不过PHPinfo() 函数被服务器 禁用了,  那就看看PHP版本算了
通过 echo phpversion()  看到了 服务器使用的是 5.3.29 PHP版本,  5.3正好满足我们的要求, 5.3 也是一个很不错的版本 以及 5.4
还有就是 免费主机 多人使用, 资源效率不高, 以及加速扩展也没有, 不过还是很流畅的运行着

文章来源:本文转载自互联网

1. 本站所有资源均来源于用户上传和网络,如有侵权请联系站长!
2. 分享目的仅供大家学习和交流,请在下载后24小时内删除!
3. 不得用于商业用途,不得违反国家法律。否则后果自负!
4. 本站提供的源码、模板、插件等等其他资源,均不包含技术服务请知悉!
5. 本站资源售价只是赞助,赞助费用仅维持本站的日常运营所需!
云码库 » HY-BBS论坛源码 v1.0

发表评论

提供最优质的资源集合

立即查看 了解详情